Playroom Printer Outage

Incident Report for Adovasio

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 11:30 EDT

Update

This is a reminder that the Playroom Printer is still out of service. This is likely caused by a paper jam. Until this is fixed, please use the printer named "Nicks Office Printer."
Posted Sep 09, 2025 - 22:11 EDT

Investigating

The Playroom printer is currently out of service. Please use the printer in Nick's Office.
Posted Sep 04, 2025 - 19:37 EDT
This incident affected: Printing (Playroom Printer).